[Pkg-javascript-commits] [less.js] annotated tag v1.5.0-b1 created (now 78cf6b2)

Jonas Smedegaard dr at jones.dk
Mon Oct 26 23:22:16 UTC 2015


This is an automated email from the git hooks/post-receive script.

js pushed a change to annotated tag v1.5.0-b1
in repository less.js.

        at  78cf6b2   (tag)
   tagging  3cc76e6541102e2d307b1828b74976a0fa0419fc (commit)
  replaces  v1.4.2
 tagged by  Luke Page
        on  Wed Sep 11 07:16:02 2013 +0100

- Log -----------------------------------------------------------------
v1.5.0-b1

Byron Wong (4):
      initial fix in browser.js and a small test addition
      take out log
      take out previous inline test attempt. add new test to runner-browser to test inline LESS
      simplify  by saving reference to style tag instead of saving index

Daniel Katz (2):
      Added support and tests for !merge() syntax #700
      Syntax changed to !merge(space | comma)

Daniel Stockman (7):
      Refactor parser's private getLocation method for clarity, and reuse appropriately.
      JSHint lib/* and test runners.
      Run JSHint in pretest phase, with basic config and ignores.
      Log stacks when errors are caught in tests to aid debugging.
      Merge branch 'sm/jshint' into all-sourcemap-patches
      Merge branch 'sm/location-refactor' into all-sourcemap-patches
      Merge branch 'sm/log-stacks' into all-sourcemap-patches

David Cornu (1):
      Catch errors thrown by root.toCSS()

ForbesLindesay (1):
      Fix global variable leaks

Hector G. Parra (1):
      Report bugs to: http://github.com/less/less.js/issues

Jon Schlinkert (2):
      resolves #964
      Merge pull request #1449 from jonschlinkert/master

Kevin Gillette (3):
      Added min and max builtins.
      min/max now always reduce compatible terms.
      Cleanup. Now responds to env.compress

Kim Joar Bekkelund (2):
      Simplify ifs
      Remove ;

Luke Page (94):
      start seperating browser load stylesheet and loadFile
      Move parsing into loadStylesheet from loadFile
      move browser to parse inside parser
      seperate sheet and env
      Simplify more of loadFile and make more of the env creation common between node and browser
      move new parseEnv into parser
      Align the callback param orders
      Add import inline option. Fixes #1209
      multi comments in selectors and other places
      Fix modifyVars to use a per file cache so less is re-evaluated properly. Also add tests and \n in case of comment on the last line
      1.4.1 so far changelog changes
      Add silent option
      Basic functionality and basic tests for import silent
      import silent - handle selectors containing amp
      import silent: add tests for extends
      import silent to work with media queries and directives
      support comments. Add failing test case for when mixin call does not have parent selectors
      todo to fix last part of import silent
      changelog info
      Fix the rest of import silent
      rename import silent to import mute. Fixes #1210
      Add bypass for saturate(5%) filter function. Helps issue #1299
      Fix merge tests when running in phantomjs
      Convert property merging to the new agreed syntax of +:
      move call to initiate loading of styles to the end of browser.js in case of syncronous load - make sure all the functions have been assigned before starting up
      add tests and fix whitespace issue
      do not use spaces between | namespace operators. Fixes #1300
      Add svg-gradient function. Fixes #1383
      guards on css styles, first draft. Only allows guards on 1 selector in the block, that being the last one.
      update changelog
      update changelog to add svg-gradient function
      add option to disable javascript. Fixes #688
      Fix typo in changelog
      Start abstracting re-organising logic into a visitor before css output. Will allow nodes to just be 'read' and debugInfo written into a sourcemap. part 1.
      move comment filtering into visitor
      remove variables before toCSS
      move the property check out of the ruleset and fix an issue in the visitor
      switch to use the clean-css compressor. #1349
      better environment detection
      start refactoring toCSS so we will be able to collect sourcemap information at the same time
      start moving the tab indent so that css is not modified once output
      get closer moving tab control away replacing text after converting to css
      fix tests
      move rule/ruleset re-ordering away from toCSS
      Fix error in previous commit
      housekeeping ready for next part of refactoring
      Move more toCSS logic into the toCSS visitor
      move rule duplication removal into the toCSS visitor
      refactor toCSS to be in output order
      move mergerules into toCSS visitor
      edit to show bug in extends. move selector toCSS to be concurrent
      continue moving to genCSS
      Merge remote-tracking branch 'evocateur/all-sourcemap-patches' into sourcemaps-wip
      Fix jshint errors after merge and add jshint to makefile
      move more files over to use genCSS
      convert the rest of the nodes to use genCSS
      add sourcemapper class
      hack in prototype exporting empty source-map
      add tests for sourcemaps and get prototype working
      tweaks and start of output
      get the map file outputting and reference file from the end of the css file
      small fixes to sourcemaps
      update jam version
      Merge branch 'lessmaster' into 1.5.0-wip
      Merge branch '1.5.0-wip' into sourcemaps-wip
      unused variable cleanup
      pass more lines and columns to the sourcemap generator. start passing the filenames to the sourcemap generator.
      test some more advanced sourcemaps and correct a bug in the output column
      correct some paths
      switch to use the clean-css compressor. #1349
      Fix issue with svg-gradient breaking the opacity
      correct radial gradient format to w3c spec
      Fix issue with css guards not hiding inner classes
      sourcemaps: rename rootpath to basepath and add a rootpath option
      sourcemaps: Fix some issues with output, add an inline flag, add a test harness
      Merge branch 'sourcemaps-wip' into 1.5.0-wip
      Fix possible race condition in the import
      Fix bad reliance on env variable, causing error when interpolating a comma seperated value
      Fix IE8 issue if 'less' is a dom element
      implement log to console and fix browser tests
      add tests and fix log to console feature
      Merge branch '1.5.0-wip' of https://github.com/gitaarik/less.js into 1.5.0-wip
      Use the log method for logging errors and turn the number into an
      Merge branch 'master' of https://github.com/TooBug/less.js into 1.5.0-wip
      rename log_level to logLevel and update some of the changelog
      switch on latedef option and fix issues. Fixes #1521
      Fix bug with extends. Fixes issue with added space with extend. Now all unit tests pass again
      Fix another extend issue - Fixes #1404
      fix media query bug. Fixes #1502
      Merge branch 'normalized-urls' of https://github.com/rjgotten/less.js into 1.5.0-wip
      Fix browser tests after removing .. path elements
      Merge branch 'patch-1' of https://github.com/quarterto/less.js into 1.5.0-wip
      don't strip units when compressing for durations
      1.5.0 beta 1

Matt Brennan (1):
      Better "JavaScript evaluation error" message

Oliver Wong (2):
      fix dom manipulation
      use already existing head var

Rik (2):
      created less.log_level setting
      added semi-colons to end of lines where missing

Roman Ožana (1):
      Improve comments stripping in compress

TooBug (1):
      fix an error about extract

agatronic (3):
      Add interface for a file loader rather than an importer
      Change node to use the file loader interface
      rename mute to reference

rjgotten (1):
      Normalize URLs in generated CSS

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-javascript/less.js.git



More information about the Pkg-javascript-commits mailing list