[Pkg-libburnia-devel] Bug#789260: libburn4: Incompatibility with Plextor PX-608CU burner

Thomas Schmitt scdbackup at gmx.net
Thu Jun 25 09:55:30 UTC 2015


> So I've downloaded and compiled 1.3.4 versions of libburn,
> libisoburn and libisofs. After that I've tried brasero again and it failed,
> but with different error.

What error messages exactly ?

It would be no surprise if it fails at different block address
or with different error messages, as long as the messages
indicate the same failure of ioctl(SG_IO).
(See below about commits 5180 + 5187.)

Even a single success would be not enough. It must work multiple
times in a row, in order to be significant.

> Seems to me that libburn/libisoburn is the main
> cause of problems.

It is nearest to the problem, at least, because it sits
between Brasero and the kernel's ioctl(SG_IO).

If you can point me to a version that reliably succeeds and
one that reliably fails, then there is hope to find the
decisive difference.

libburn-1.3.2 was released Aug 7 2013
libburn-1.3.4 on Dec 12 2013
Current is
It should work flawlessly with applications which expect older
versions since about 0.4.0.
All older release tarballs can be found at:

libburn has two levels, where differences may have occured:

- The system adapter libburn/sg-linux.c which handles all
  Linux-specific aspects. Among them SG_IO for transport of
  SCSI/MMC commands and replies.
  Its history can be inspected via
  No good suspect to see there:
  Commits 5180 + 5187 promise better error messages in 1.3.4
  in comparison to 1.3.2.
  Commits 5218, 5225, 5335 are supposed to be unrelated to
  SCSI transport.
  Commit 5368 was used to diagnose problems with SATA on an
  ARM board. (USB worked flawlessly on the same machine, SATA
  produced hick-ups and echoed command relies. Sometimes it
  worked for a single burn run. Mostly not. The user finally
  settled with USB.)
- The higher functions of libburn could change the wear
  pattern of controller and drive by causing SCSI commands
  beeing sent in different sequences.

  It seems futile to inspect all changsets between 5132
  (when 1.3.2 was freshly out and development step 1.3.3 started)
  and 5426 (after which current release 1.4.0 went out).
  One would rather have to compare SCSI logs of versions
  in order to detect decisive differences.

  In libburn-1.X.Y directory (after ./configre && make, to get libburn
  compiled and cdrskin/compile_cdrskin.sh to get a staticaly linked
  cdrskin, which needs no "make install"):

    cdrskin/cdrskin -V dev=/dev/sr0 blank=as_needed -eject image.iso \
      2>&1 | tee -i /tmp/cdrskin-1.X.Y.log
  A successful run will produce a WRITE(10) message for every
  32 KB. So the log files might become quite large.

Have a nice day :)


More information about the Pkg-libburnia-devel mailing list