[Pkg-libvirt-commits] [libguestfs] 32/61: builder: rename "program_name" into "progname"
Hilko Bengen
bengen at moszumanska.debian.org
Fri Oct 31 19:09:38 UTC 2014
This is an automated email from the git hooks/post-receive script.
bengen pushed a commit to annotated tag debian/1%1.28.2-1
in repository libguestfs.
commit fd12fcb908bb38cf594a541beffb8b429adfd66d
Author: Pino Toscano <ptoscano at redhat.com>
Date: Fri Oct 17 14:46:40 2014 +0200
builder: rename "program_name" into "progname"
"program_name" is already used as shorthand define for
program_invocation_short_name.
(cherry picked from commit d2c853f41435c6ac7507f4c152efef7ba7d0ec7c)
---
builder/index-parse.y | 4 ++--
builder/index-parser-c.c | 2 +-
builder/index-struct.h | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/builder/index-parse.y b/builder/index-parse.y
index 06e6a83..36f9f07 100644
--- a/builder/index-parse.y
+++ b/builder/index-parse.y
@@ -153,8 +153,8 @@ yyerror (YYLTYPE * yylloc, yyscan_t scanner, struct parse_context *context, cons
int has_suffix = context->error_suffix != NULL && context->error_suffix[0] != 0;
fprintf (stderr, "%s%s%s%ssyntax error at line %d: %s%s%s\n",
- context->program_name ? context->program_name : "",
- context->program_name ? ": " : "",
+ context->progname ? context->progname : "",
+ context->progname ? ": " : "",
context->input_file ? context->input_file : "",
context->input_file ? ": " : "",
yylloc->first_line, msg,
diff --git a/builder/index-parser-c.c b/builder/index-parser-c.c
index 099bdf8..845abd7 100644
--- a/builder/index-parser-c.c
+++ b/builder/index-parser-c.c
@@ -56,7 +56,7 @@ virt_builder_parse_index (value progv, value error_suffixv, value filenamev)
FILE *in;
parse_context_init (&context);
- context.program_name = String_val (progv);
+ context.progname = String_val (progv);
context.input_file = String_val (filenamev);
context.error_suffix = String_val (error_suffixv);
diff --git a/builder/index-struct.h b/builder/index-struct.h
index 150535d..ada35e3 100644
--- a/builder/index-struct.h
+++ b/builder/index-struct.h
@@ -44,7 +44,7 @@ struct parse_context {
*/
int seen_comments;
const char *input_file;
- const char *program_name;
+ const char *progname;
const char *error_suffix;
};
--
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/pkg-libvirt/libguestfs.git
More information about the Pkg-libvirt-commits
mailing list