[Pkg-linaro-lava-devel] Bug#900971: lava: FTBFS when built with dpkg-buildpackage -A

Santiago Vila sanvila at unex.es
Thu Jun 7 13:19:22 BST 2018

Package: lava
Version: 2018.5-2
Severity: serious

Dear maintainer:

I tried to build this package with dpkg-buildpackage -A and it failed:

 dpkg-source --before-build lava-2018.5
 fakeroot debian/rules clean
dh clean --with sphinxdoc,systemd,python3
dh: unable to load addon sphinxdoc: Can't locate Debian/Debhelper/Sequence/sphinxdoc.pm in @INC (you may need to install the Debian::Debhelper::Sequence::sphinxdoc module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.2 /usr/local/share/perl/5.26.2 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at (eval 7) line 1.
BEGIN failed--compilation aborted at (eval 7) line 1.

make: *** [debian/rules:36: clean] Error 2
dpkg-buildpackage: error: fakeroot debian/rules clean subprocess returned exit status 2

I have not tried several times because the error message suggests some
kind of missing build-dependency.

To reproduce please try building with dpkg-buildpackage -A on a
chroot having only the essential packages (plus those required
for "dpkg-buildpackage -A" to work).

Full build log available here:



More information about the Pkg-linaro-lava-devel mailing list