Bug#798111: Illegal instruction after compiling some code

Sylvestre Ledru sylvestre at debian.org
Sun Sep 4 13:32:48 UTC 2016

tag 798111 moreinfo

Le 05/09/2015 à 20:55, Julien Puydt a écrit :
> Package: clang-3.8
> Version: 1:3.8.0~svn245286-1
> I tried to compile flint 2.5.2 (http://flintlib.org -- or the orig sources of experimental's flint package) with this version of clang to check if a problem I had with gcc 5 was compiler-related, but it gave me other problems : it compiled the lib and some tests ok, but when trying to actually run
> those tests, I had failures "Illegal instruction".
> Using clang version 3.5.2-2 (tags/RELEASE_352/final) (based on LLVM 3.5.2) gave the same result, but I prefer reporting on the last version.
> I configured the sources like this:
> CC=clang-3.8 ./configure --prefix=/usr --with-ntl CFLAGS='-D_FORTIFY_SOURCE=2 -g -O2 -fstack-protector-strong -Wformat -Werror=format-security'
>Sorry but I will  need more information to be able to anything here...
A test case would be the best.


More information about the Pkg-llvm-team mailing list