[Pkg-lxde-maintainers] Bug#966363: Failed to execute child process “xterm” (No such file or directory)

debian-testing debian-testing at protonmail.com
Mon Jul 27 14:21:26 BST 2020

Package: pcmanfm
Version: 1.3.1-1+b1

When double-clicking (executing) an executable script (.sh) from PCManFM, the following error occurs: "Failed to execute child process “xterm” (No such file or directory)". Executing from a double-click previously worked correctly.

The source of the error is that the following entry is missing:
File: ~/.config/libfm/libfm.conf

Missing Entry: terminal=x-terminal-emulator %s

Re-adding the above entry to the above file solved the problem (eliminates the error) after a reboot.

I have had this error several times on different systems running Debian 11 Bullseye with lxde-core. The error seems to always happen after an attempted "apt update" which fails while in progress because the disk become full and then a reboot.

I have not be able to isolate if the source cause is the update or the reboot with a full disk. My best guess would be that it occurs after a reboot with a full disk and that lxde is replacing the libfm.conf with a default minimal version.

uname -a:
Linux hostname 5.7.0-1-amd64 #1 SMP Debian 5.7.6-1 (2020-06-24) x86_64 GNU/Linux
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/pkg-lxde-maintainers/attachments/20200727/577544fa/attachment.html>

More information about the Pkg-lxde-maintainers mailing list