ffmpeg error

Leslie Rhorer lrhorer at satx.rr.com
Wed Oct 28 03:22:13 UTC 2009

	Hello.  This is my first posting to the list.  If I need to
subscribe to the list, please respond with a target URL where I can
subscribe.  Otherwise, please respond directly to me.  I am using ffmpeg
with an application called pyTivo which calls it with the following syntax:

/usr/bin/ffmpeg -i <filename> -vcodec mpeg2video -b 16384k -maxrate 30000k
-bufsize 4096k -ab 448k -ar 44100 -acodec ac3 -copyts -f vob -

	ffmpeg responds with:

Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '<filename>':
  Duration: 00:13:12.4, start: 0.000000, bitrate: 927 kb/s
    Stream #0.0(eng): Video: h264, yuv420p, 480x320 [PAR 0:1 DAR 0:1], 29.97
    Stream #0.1(eng): Audio: mpeg4aac, 44100 Hz, stereo
Unknown encoder 'mpeg2video'

	How should I go about repairing this situation?

	On a related note, I want to create MP4 / h.264 videos using ffmpeg,
but the coders do not seem to be installed.  I tried getting the source code
and compiling it, but I could not get a fully successful compile.  I finally
got ffmpeg, libx264, and libfaac to build, but for some reason the libx264
didn't like my version of yasm, and I had to disable asm compilation. I was
then able to compile, and the resultant binary would run, but when I tried
to use the libx264 codec, I got a segmentation fault.

	The pertinent info:

RAID-Server:/usr/share/pyTivo# ffmpeg -version
FFmpeg version r11872+debian_0.svn20080206-18, Copyright (c) 2000-2008
Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-libfaad --enable-pp --enable-swscaler
--enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora
--enable-libvorbis --enable-pthreads --disable-strip --enable-libdc1394
--enable-shared --disable-static
  libavutil version: 49.6.0
  libavcodec version: 51.50.0
  libavformat version: 52.7.0
  libavdevice version: 52.0.0
  built on Jul  2 2009 03:48:11, gcc: 4.3.2
FFmpeg r11872+debian_0.svn20080206-18
libavutil   3212800
libavcodec  3355136
libavformat 3409664
libavdevice 3407872
RAID-Server:/usr/share/pyTivo# uname -a
Linux RAID-Server 2.6.26-2-amd64 #1 SMP Thu May 28 21:28:49 UTC 2009 x86_64

This on an AMD Athlon 64 X 2 running "Lenny".

More information about the pkg-multimedia-maintainers mailing list