Bug#963013: invada-studio-plugins-lv2 edit dialog suil error

Paulo S. Pinheiro pinus.sc at gmail.com
Wed Jun 17 19:09:39 BST 2020

Package: invada-studio-plugins-lv2

Version: 1.2.0+repack0-8

Uname: Linux 5.4.0-37-lowlatency x86_64

DistroRelease: Ubuntu 20.04


*I've tried before to report thist bug in Lanunchpad to Ubuntu 
Developers, but they directed me to Debian, because they import the 
package unchanged.*

Here's what happens:
Since I upgraded to Ubuntustudio 20.04 (Intel 64-bit) I can't open the INVADA plugins edit dialog on Ardour5 (rev 1:5.12.0-3ubuntu4). No error message dialog.
Running Ardour5 on terminal and trying again I get the following message line (example: Invada Early Reflection Reverb):
    "suil error: Unable to open UI library /usr/lib/lv2/invada.lv2/inv_erreverb_gui.so (/usr/lib/lv2/invada.lv2/inv_erreverb_gui.so: undefined symbol:__sinh_finite)"*.

The inv_erreverb_gui.so* is correctly in */usr/lib/liv2/invada.lv2 directory.

The Ardour native generic control editor dialog works fine for the plugins.

I noticed some LV2 plugins editors open correctly, some others don't. Here are the ones with the problem:
. Invada Compressor
. Invada Early Reflection Reverb
. Invada High Pass Filter
. Invada Input Module
. Invada Low Pass Filter
. Invada Meter
. Invada Stereo Phaser
. Invada Tube Distortion

The "good" ones:
. Invada Delay Munge
. Invada Test Tones

The error messages for the other problematic plugins are similar to the  one above. The files are all there on the expected directory. Haven't find any workaround by Ubuntu Studio or Ardour.

When I tried to compile the Ubuntu package (invada-studio-plugins-lv2_1.2.0+repack0) from source I got the error:

"dpkg-checkbuilddeps: erro: Unmet build dependencies: debhelper (>= 11) libgtk2.0-dev lv2-dev"

In my system I have:
debhelper: 12.10ubuntu1
libgtk2.0-dev: 2.24.32-4ubuntu4
lv2-dev: 1.16.0-1

So, it seems to me that the plugin is not compatible with the new libgtk2.0-dev library, and/or lv2-dev.

But I'm very newbie.

Any other information you need to solve the problem, please let me know.

Thank you in Advance

Paulo S. Pinheiro	

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/pkg-multimedia-maintainers/attachments/20200617/7969e6c4/attachment.html>

More information about the pkg-multimedia-maintainers mailing list