[debian-mysql] Bug#660206: Bug#660206: This is a regression

Clint Byrum clint at fewbar.com
Mon Apr 9 17:21:08 UTC 2012

Excerpts from micah anderson's message of Sun Apr 08 10:13:40 -0700 2012:
> severity 660206 serious
> thanks
> This is actually a regression, the only way to get things to work again
> is to downgrade package like such:
> apt-get install mysql-server-5.1=5.1.49-3 mysql-client-5.1=5.1.49-3
> mysql-common=5.1.49-3 mysql-server-core-5.1=5.1.49-3
> libmysqlclient16=5.1.49-3
> micah

So, I'm not sure I agree that this is such a serious regression. *lenny*
shipped with rails 2.1.0. 1.2.6 was released in 2007, and is not supported
in Debian at all. The referenced upstream bug talks about using client
versions older than 4.1, which is basically ancient.

I'm not disputing that this is a regression introduced by the upstream
jump to 5.1.61, but I don't know that its worth downgrading and losing
security updates for. Perhaps the client libraries should be updated to
something that is still supported by upstream and/or Debian.

More information about the pkg-mysql-maint mailing list