[Pkg-net-snmp-devel] Bug#635616: Virtio interfaces have the speed to 0

Hideki Yamane henrich at debian.or.jp
Fri Apr 26 06:48:41 UTC 2013


On Sat, 20 Apr 2013 15:16:09 +0200
Laurent LEGENDRE <geminux50 at gmail.com> wrote:
> Hi, I have the same bug in squeeze and wheezy so I suppose it's not solved
> yet.

 I've tried to reproduce it, failed and succeeded.
 It means, one KVM environment returns proper value, and another returns 
 nothing. Both VM are sid, difference is failed one uses virtio network device.

 Please try to install ethtool and check it via
 # ethtool eth0 (or eth1)

 then, if your environment is sane, it returns many values. if not, it
 only send "Linkdetected: yes" to you. IMO, it's not net-snmp bug, but
 KVM and/or libvirt issue (because it cannot get any value from system).

> In the meanwhile, is there any workaround ?

 How about using e1000 for quest VM NIC, instead?


 Hideki Yamane     henrich @ debian.or.jp/org

More information about the Pkg-net-snmp-devel mailing list