[Pkg-netatalk-devel] Bug#806217: Bug#806217: netatalk: Mac fails to copy files to netatalk server with error -50

Jochen Pawletta jochen at hin.de
Thu Nov 26 08:26:37 UTC 2015

Am Wednesday, 2015-11-25 um 21:22:21 +0100 schrieb Jonas Smedegaard:


> >> Did you set the option "ea"?
> >
> > I tried that, but it seems to be ignored ... :-(
> Well, that smells of a syntax issue (either you making a typo or 
> misunderstanding how/where to put that option, or code having a bug in 
> its configfile parser).
> Just trying to be optimistic here... :-)

I tried it this way:

:DEFAULT: cnidscheme:dbd ea:ad options:upriv,usedots

I also tried it this way:

/var/local/samba \
  "Samba Freigabe" \
  allow:jochen,andrea \
  options:upriv,usedots \

> >>> Is this problem fixed in netatalk 2.2.5?
> >>
> >> Not sure.  Please do try, and report back your findings to this 
> >> bugreport: http://snapshot.debian.org/package/netatalk/
> >
> > Are these packages jessie-compatible?
> > I don't want to upgrady everything to unstable only to test this ...
> Should be: Netatalk was 2.2.5-1 was kicked out of testing at the 
> beginning of its "freeze" (i.e. last stage before becoming stable).

OK, I tried 2.2.5-1+b1 - no change.
I also have to mount with "noacl"-option to get it working.

> > (OSMC -> Open Source Media Center, formerly known as XBMC)
> >  https://osmc.tv/
> Hm.  Seems from http://kodi.wiki/view/OSMC that _Kodi_ is the successor 
> of (the code) XBMC, whereas OSMC is a distribution around XBMC/Kodi.
> Please consider using the Debian packaged Kodi - it might be backported 
> to stable.

I use OSMC on my RaspBerry Pi, it works fine ...
(Not now anymore, but that is a samba-problem I think.)

> And please, if you file bugreports in Debian but the issues you 
> experienced occurred in a derivative of Debian (which OSMC seems to be) 
> then you are *STRONGLY* recommended to mention so *VERY* explicitly, to 
> avoid Debian developers getting frustrated (to put it mildly) if later 
> realizing they've wasted time debugging someone elses problem!

I never ever expected any answer on this question, it was ment to be
only a side note ... :-)


ZX81 - C64 - Amiga - x86-Linux - iMac (OS X)

More information about the pkg-netatalk-devel mailing list