Bug#612956: nvidia-glx requires xorg-video-abi-8.0 but new xserver-xorg-core provides xorg-video-abi-8

Craig Sanders cas at taz.net.au
Fri Feb 18 23:44:51 UTC 2011

more detail on xorg-video-abi-8.0 vs xorg-video-abi-8

xserver-xorg-core 2:1.9.4-1 Provides both of them, but 2:1.9.4-2
Provides only xorg-video-abi-8:

Package: xserver-xorg-core
Version: 2:1.9.4-1
Provides: xorg-input-abi-11, xorg-input-abi-11.0, xorg-video-abi-8, xorg-video-abi-8.0

Package: xserver-xorg-core
Version: 2:1.9.4-2
Provides: xorg-input-abi-11, xorg-video-abi-8

nvidia-glx 260.19.21-1 depends on xorg-video-abi-8.0:

Package: nvidia-glx
Version: 260.19.21-1
Depends: libgl1-nvidia-glx (= 260.19.21-1), libglx-nvidia-alternatives, nvidia-kernel-260.19.21, xorg-video-abi-8.0 | xorg-video-abi-6.0 | xserver-xorg-core (<< 2:1.7.7), libc6 (>= 2.2.5)
Conflicts: fglrx-driver, nvidia-glx, nvidia-glx-legacy, nvidia-glx-legacy-173xx, nvidia-glx-legacy-71xx, nvidia-glx-legacy-96xx

so attempting to upgrade xserver-xorg-core to 1.9.4-2 fails to provide
nvidia-glx's required dependancies.

not sure if this bug belongs to nvidia-glx or xserver-xorg-core, but the solution
requires co-ordination between the two packages.


PS: why does nvidia-glx conflict with itself in the Conflicts: line
above? i know it's been in the package since at least 195.36.31 without
causing problems, but it seems an odd conflict to have.

'aptitude why-not nvidia-glx' says that that is the problem (it's wrong,
the problem is the missing dependancy xorg-video-abi-8.0).

# aptitude why-not nvidia-glx
ih  nvidia-glx Conflicts nvidia-glx

craig sanders <cas at taz.net.au>

More information about the pkg-nvidia-devel mailing list