Bug#642497: nvidia-glx: incorrect rendering followed by xserver infinite loop when using some OpenGL apps

Andreas Beckmann debian at abeckmann.de
Sat Sep 24 07:24:51 UTC 2011

tag 642497 upstream moreinfo

On 2011-09-23 05:30, jack wrote:
> I had nvidia-glx and X running well on Wheezy installed July 23,2011 on a new PC with an NVIDIA 560 Ti card.
> After an apt-get upgrade on August 17, the OpenGL features are no longer working correctly and I haven't been
> able to restore the system, even when rolling back to July 23 versions (nvidia-glx=275.09.07-5 and xserver-xorg-core=

In that case, probably some other change introduced in the Aug 17 update
caused these problems. /var/log/dpkg.log*, /var/log/term.log*,
/var/log/aptitude* should contain your upgrade history.

> OpenGL problems seen in 3 different packages:

There is nothing we can do about these problems in the closed source
driver. Please report them directly to NVIDIA, following their bug
reporting instructions:

>    [ 672.814] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
>    The Xserver infinite loop problem was mitigating by adding to xorg.conf
>            Option         "IgnoreABI" "True"

can't be, this should be completely unrelated

>    but the Xserver became unusable in that it was impossible to scroll down and select an item
>    from a list (for example a music list in totem). Commands like 'less' on a gnome-terminal
>    scrolled endlessly even though resize shows the correct number of lines and columns. 
> I tried rolling back to the xserver and nvidia-glx versions on July 23, when these worked fine,
> but the problems persisted.

Have you tried creating a completely new user account (with no
accumulated cruft in his dot-files) and testing as this user?

Turning off desktop effects has also helped some users.

> I also tried installing the Nvidia driver directly from the NVIDIA package, without dkms, but
> the problem was the same.

Another sign that this is not a packaging issue.

> Bug 641344 describes rendering problems with xserver and nvidia for versions
>   xserver-xorg-core 2:1.11.0-1
>   xserver-xorg-video-nvidia 285.03-2

Xserver 1.11.0 is problematic, a fix has been submitted to upstream and
will be included in 1.11.1, but if you stayed with 1.10.x this should be
not your issue.

> Linux berkeley 2.6.39-2-686-pae #1 SMP Tue Jul 5 03:48:49 UTC 2011 i686 GNU/Linux

Have you tried a different kernel version/flavor?

If you report this to NVIDIA, please post the URL to the corresponding
forum thread to this Debian bug report, so that others may follow progress.


More information about the pkg-nvidia-devel mailing list