Bug#764146: nvidia-opencl-icd: Should depend on nvidia-cuda-toolkit

Andreas Beckmann anbe at debian.org
Sun Oct 5 20:30:29 UTC 2014

reassign -1 src:darktable 1.4.2-1

On 2014-10-05 21:36, Michael Below wrote:
> I tried to use darktable with OpenCL support, to no success: clinfo would
> show the nvidia OpenCL support, but darktable wasn't able to use
> it for image processing.
> Thanks to
> https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1311362/comments/7
> I installed nvidia-cuda-toolkit, now it works. That solution was
> initially proposed for a different application, so it seems to be
> a general problem.

darktable needs to dlopen(libOpenCL.so.1) not dlopen(libOpenCL.so)

> As I understand it, the CUDA infrastructure is needed for NVidia
> OpenCL. If that's so, nvidia-opencl-icd should depend on it.

Installing any package providing opencl-dev would have provided the
libOpenCL.so symlink. But this shouldn't be used by applications.


More information about the pkg-nvidia-devel mailing list