Bug#756522: bumblebee-nvidia: cannot access secondary gpu - error: Permission denied

Dirk Linnerkamp dirk.linnerkamp at online.de
Sun Jan 4 12:21:38 UTC 2015

Hi Vincent,

Am 04.01.2015 um 09:02 schrieb Vincent Cheng:

Hi Dirk,
> Sorry for the late reply! Please do take care to cc the actual bug
> report as well instead of directly replying only to me (there's a good
> chance for stuff to just get lost in my inbox, unfortunately).
> On Fri, Nov 21, 2014 at 2:14 PM, Dirk Linnerkamp
> <dirk.linnerkamp at online.de> wrote:
>> Dear Maintainer,
>> since I've the same issue with the same Debian-Jessie System and bumblebee I
>> feel free  to answer your message and provide the additional Information you
>> asked for.
>> My "bumblebee", "xserver-xorg" and "xserver-common" versions are the same as
>> in Mareks post which I answer.
>> I've attached a file with all information you requested.
> Next time please either reply inline or put everything into a text
> file, not an OpenOffice/LibreOffice Writer document.
..yes, sorry I'll do so..

> According to your /var/log/Xorg.8.log logfile, it looks like the
> problem is that for some reason the nvidia driver is unable to detect
> your nvidia GPU, i.e.
> [ 9176.525] (II) NVIDIA dlloader X Driver 340.46 Wed Sep 24 13:34:03 PDT 2014
> [ 9176.525] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
> [ 9176.525] (­­) using VT number 7
> [ 9176.525] (EE) No devices detected.
> [ 9176.525] (EE)
> Fatal server error:
> [ 9176.525] (EE) no screens found(EE)
> [ 9176.525] (EE)
> Please consult the The X.Org Foundation support
> for help.
> at http://wiki.x.org
> Is your nvidia GPU supported by nvidia-driver 340.46? See supported
> products section at [1]. Otherwise, you may have to set the BusID
> manually in /etc/bumblebee/xorg.conf.nvidia. Refer to the comments in
> that file for a brief howto.
> Regards,
> Vincent
> [1] http://www.nvidia.com/download/driverresults.aspx/78469/en-us

Meanwhile I found the solution which I posted on GitHub where I looked 
also for a solution. See the conversation here:


The solution (for me) was, that I had to DELETE the BusID parameter in 
my "/etc/bumblebee/xorg.conf.nvidia". I set this parameter at first 
manually, as you suggested. I checked twice if it was the correct 
number, but the error message remained.

After deleting it, bumblebee worked! A "vblank_mode=0 optirun -b primus 
glxgears -info" now gave me 945 fps instead of the 60 and a "cat 
/proc/acpi/bbswitch" showed me the card was ON.

But whenever I UNCOMMENT the "BusID:xxx" line  in the xorg.conf.nvidia, 
the error message returned again.

I can't say for sure, if the latest nvidia driver update to version 
340.65-2 has something to do with it too, as was mentioned on GitHub, 
because I'm not sure any longer, if I tried bumblebee the first time 
without this parameter also or not. I only know that I set and uncomment 
it then.

Thanks for answering and

Kind Regards

Dirk Linnerkamp

More information about the pkg-nvidia-devel mailing list