Bug#776598: bumblebee-nvidia: Cannot access secondary GPU - error: X did not start properly

solitone solitone at mail.com
Thu Jan 29 20:18:28 UTC 2015

Package: bumblebee-nvidia
Version: 3.2.1-4~bpo70+1
Severity: important

Dear Maintainer,

I have bumblebee-nvidia 3.2.1-4~bpo7 and nvidia-driver 340.65-2~bpo on 
an amd64 architecture laptop. My kernel version is: 

$ uname -a
Linux aldous 3.16.0-0.bpo.4-amd64 #1 SMP Debian 3.16.7-ckt2-1~bpo70+1 (2014-12-08) x86_64 GNU/Linux

After all packages were succesfully installed, I tried and ran:

$ optirun glxspheres64

to test whether everything worked fine. I got this error message though:

[ERROR]Cannot access secondary GPU - error: Could not load GPU driver

I then edited /etc/bumblebee/bumblebeehihi.conf, and changed "KernelDriver=nvidia"
to "KernelDriver=nvidia-current", then restarted the bumblebee daemon.

I retried the test with optirun, but this time I got a different error message:

[18100.861997] [ERROR]Cannot access secondary GPU - error: X did not start properly
[18100.862071] [ERROR]Aborting because fallback start is disabled.

-- System Information:
Debian Release: 7.8
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-0.bpo.4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages bumblebee-nvidia depends on:
ii  bumblebee           3.2.1-4~bpo70+1
ii  nvidia-driver       340.65-2~bpo70+1
ii  nvidia-glx          340.65-2~bpo70+1
ii  nvidia-kernel-dkms  340.65-2~bpo70+1

bumblebee-nvidia recommends no packages.

bumblebee-nvidia suggests no packages.

-- no debconf information

More information about the pkg-nvidia-devel mailing list