nvidia-cuda-toolkit 6.5 transition - pycuda bits

Graham Inggs ginggs at debian.org
Mon Sep 21 08:50:44 UTC 2015

On 13/09/2015 21:26, Tomasz Rybak wrote:

> My machine with NVIDIA hardware had problems building PyCUDA
> with GCC 5. I've built packages on other machine using pbuilder,
> and it works.

I ran some of the pycuda examples and they worked, but I didn't try all 
of them.

I've just noticed LP: 1497663 [1] reported in Ubuntu.
I am now trying to build all cuda-samples on Ubuntu Wily and when 
compiling some of the samples I get errors similar to those reported in 
the bug.

/usr/include/c++/5/bits/locale_classes.h(789) (col. 20): internal error: 
assertion failed at: 
line 8408
1 catastrophic error detected in the compilation of 
Compilation aborted.
Aborted (core dumped)

I am using nvidia-cuda-toolkit 6.5.14-1ubuntu1 (includes the patch to 
allow gcc 5), nvidia-graphics-driver 340.93-0ubuntu1, gcc 4:5.2.1-3ubuntu1.

Do we need to revert to using the gcc/g++ wrappers?

[1] https://bugs.launchpad.net/bugs/1497663

More information about the pkg-nvidia-devel mailing list