Bug#818763: nvidia-kernel-dkms: fail to load nvidia-uvm (again)

Andreas Beckmann anbe at debian.org
Sun Mar 20 23:12:04 UTC 2016

Control: retitle -1 nvidia-kernel-dkms: autoloading nvidia-uvm fails

On 2016-03-20 22:36, Michael Below wrote:
>> sudo modprobe -v nvidia-uvm
>> What's the output?
> That just works???


> I just did a reboot, started darktable 

you start darktable manually?

> -- again, with the openCL
> errors -- tried glxgears, but now manually nvidia-uvm is loaded fine,
> and after it is loaded darktable openCL works too.
> Sorry, I jumped to a conclusion, this seems to be a different issue
> than the previous bug report.

no problem, now we have something different to investigate :-)

Which libopencl1 library are you using?
(Note to myself: collect this info in bug-control, and the installed
icds, too, and /etc/OpenCL/vendors in bug-script)

Please install the ocd-icd-libopencl1 and clinfo packages from stretch.

unload the nvidia-uvm module (nvidia will stay loaded, so X can continue
to run)

(as root)
# modprobe -r nvidia-uvm

and now try clinfo (on the nvidia platform only) to see whether the
nvidia-uvm module is loaded automatically

(as user)
$ OCL_ICD_VENDORS=nvidia.icd clinfo
$ dmesg | tail

That worked for me, i.e. nvidia-uvm got loaded automatically.

If that works, try again unloading and start darktable with
OCL_ICD_VENDORS=nvidia.icd set


More information about the pkg-nvidia-devel mailing list