Bug#831974: black screen with nvidia driver

VA bugs at indigo.re
Wed Sep 14 21:12:03 UTC 2016

So since all this time I have this ugly vesa resolution, nothing has
worked so far, the recent kernel upgrade didn't solve the problem, and
there are no updates for the nvidia driver...

However, there's something, I created a new partition and did a fresh
stable i386 install then upgrade to unstable, to ensure it was not my
old setup which had a specific problem, but it seems not.
So on that new install, I still get a black screen. dmesg shows a
desperate output:

[  100.314324] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver
for UNIX platforms  361.45.18  Tue Jun 21 17:58:16 PDT 2016
[  100.315130] nvidia-modeset: Allocated GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  100.709686] nvidia-modeset: Freed GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  101.045590] gnome-shell[1019]: segfault at 24448b2c ip b6118b81 sp
bfded03c error 4 in libc-2.24.so[b60a3000+1b1000]
[  101.449901] nvidia-modeset: Allocated GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  101.823843] nvidia-modeset: Freed GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  102.169960] gnome-shell[1074]: segfault at 24448b2c ip b60e2b81 sp
bfbd651c error 4 in libc-2.24.so[b606d000+1b1000]
[  102.546999] nvidia-modeset: Allocated GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  102.936657] nvidia-modeset: Freed GPU:0
(GPU-5e911e77-bb03-4910-7d0a-8201558cf33b) @ PCI:0000:01:00.0
[  103.259820] gnome-shell[1128]: segfault at 24448b2c ip b614bb81 sp
bfcb89dc error 4 in libc-2.24.so[b60d6000+1b1000]

And it goes on until I reset the machine.

I had a lead though, I tried another fresh stable install then upgrade
to unstable, but on amd64 this time, and this time, the nvidia driver
worked fine.

So it seems to be an architecture problem to solve.

More information about the pkg-nvidia-devel mailing list