Bug#924704: bumblebee-nvidia: nvidia-driver 410 doesn't appear to allow the unloading of the nvidia module

Daniel O. danfun360 at gmail.com
Sat Mar 16 03:39:48 GMT 2019

Package: bumblebee-nvidia
Version: 3.2.1-20
Severity: grave
Justification: renders package unusable

Dear Maintainer, I write this bug report because this bumblebee/bumblebeed
doesn't work as it should.

   * What led up to the situation? Bumblebee used to work correctly when the
nvidia driver was at 390. A few days ago it was upgraded to 410. At the time I
was running Debian Buster (testing as of this writing). That's where things
started to get problematic. It appears that the nvidia module couldn't be
unloaded or something. bbswitch reported as "ON" without optirun, and as the
nvidia drivers were considered in use, I was unable to unbind the nvidia driver
for VGA Passthrough as I had been doing before.
   * What exactly did you do (or not do) that was effective (or
     ineffective)? I uninstalled every bumblebee and nvidia package. I then
reinstalled everything. No luck. I then uninstalled everything and went for the
legacy 390 package. Unfortunately there were problems with that: nvidia-cuba-
toolkit and nvidia-cuba-dev require the latest nvidia driver installed. On top
of that, bumblebee refused to see the legacy 390 drivers as a glx alternative.
I uninstalled all the nvidia stuff again, switched to Debian Sid, and installed
the latest nvidia drivers again (they were slightly more up to date on Sid than
in Buster). Still no change.
   * What was the outcome of this action? Bumblebee should be able to blacklist
the nvidia driver and isolate it from the operating system in such a way that
the system would run on the integrated GPU and run the discrete GPU for
applications when called for.
   * What outcome did you expect instead? The nvidia driver is not blacklisted,
and the discrete GPU is in control.

On a different note, I tried posting a bug report upstream. It has some
information this report might not have (vice versa is definitely the case,
unfortunately). It can be found at https://github.com/Bumblebee-

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages bumblebee-nvidia depends on:
ii  bumblebee               3.2.1-20
ii  glx-alternative-nvidia  0.9.1
ii  nvidia-driver           410.104-1
ii  nvidia-kernel-dkms      410.104-1

bumblebee-nvidia recommends no packages.

bumblebee-nvidia suggests no packages.

-- no debconf information

More information about the pkg-nvidia-devel mailing list