Bug#335836: [Pkg-openssl-devel] Bug#335836: libssl0.9.8: library has no ciphers

Kurt Roeckx kurt at roeckx.be
Wed Oct 26 16:31:10 UTC 2005

On Wed, Oct 26, 2005 at 09:14:46AM +0200, Birger Koblitz wrote:
> Package: libssl0.9.8
> Version: 0.9.8a-2
> Severity: normal
> Several programs which worked well with 0.9.7g suddenly fail to run reporting
> 18980:error:140A90A1:SSL routines:SSL_CTX_new:library has no ciphers:ssl_lib.c:1424:

Can you please give more details about which programs fail?  We
already have alot of open bugs about this.

So far I've traced 2 of those known bugs to bugs in the
application, not calling the SSL_library_init() or equivalent
function, or using other library function before calling it.

> After googling for this I found out that the general hint is that one should recompile
> openssl manually. I did so with 0.9.8a and it worked again.

How did you compile it then?  Using upstream or debian sources?
Configuring for what target OS?

Does relinking the program against the current version in sid
also fix the problem?  Some kind of ABI breakage?

Or is the problem related to cpu specific assembler for
486/586/686, and that one of those is broken?  And your own
compiled version didn't have those?

Did you just replace the ones in /usr/lib, or did you place them
in /usr/local?


More information about the Pkg-openssl-devel mailing list