[Pkg-pascal-devel] Bug#970014: Workaround proposal

Frédéric Bonnard frediz at debian.org
Thu Sep 10 10:17:58 BST 2020

Control: tags -1 patch


I'm no Free Pascal expert but having a look at the build on fedora which
work, I saw that they pass -gw to the build command that fails here in
Debian and that works on Fedora.
Which I tried and make it work :
/usr/bin/ppcppc64 -gs -gl -Sghi -O3 -dlclqt5 -Fu. -Fu../../../components/lazutils/lib/powerpc64-linux -Fu../../../packager/units/powerpc64-linux -Fu../../../lcl/units/powerpc64-linux -Fu../../../lcl/units/powerpc64-linux/qt5 -Fu../../../components/cairocanvas/lib/powerpc64-linux/qt5 -Fu../../../components/turbopower_ipro/units/powerpc64-linux/qt5 -Fu../../../components/printers/lib/powerpc64-linux/qt5 -Fu../packages/help/lib/powerpc64-linux/qt5 -Fu/usr/lib/powerpc64le-linux-gnu/fpc/3.2.0/units/powerpc64-linux/rtl -FE. -FUlib/powerpc64-linux -Fl/usr/lib/gcc/powerpc64le-linux-gnu/10 -Flinclude -Fl/etc/ld.so.conf.d/*.conf @/<<PKGBUILDDIR>>/debian/deb-host-fpc.cfg -dpowerpc64 lhelp.lpr

Here -gs is specified :
components/chmhelp/lhelp/Makefile.fpc:options=-gs -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)

I understand from here that for 64b -gw should be better

So removing -gs in favor of -gw makes it work and everything builds, but when
lazbuild is run for "all" packages, this one crashes with :
'error while loading shared libraries: R_PPC64_ADDR16_HA reloc'

And this one, seems related to pie issues.
So I just built without pie nor -gw and -gs removal and everything
builds and runs fine.
So my workaround is that one :

I tried to detailed my tries with gs/gw in case that aspect has some
interest later.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://alioth-lists.debian.net/pipermail/pkg-pascal-devel/attachments/20200910/562332b2/attachment.sig>

More information about the Pkg-pascal-devel mailing list