[Pkg-phototools-devel] Problem using gbp, Please check packaging of new package checkit_tiff

Andreas Romeyke art1 at andreas-romeyke.de
Tue Jul 12 20:11:28 UTC 2016

Hi Andreas,

On Sun, 10 Jul 2016 18:15:31 +0200
Andreas Tille <andreas at an3as.eu> wrote:

> I tried to Build using gbp buildpackage but I get
> gbp:info: Tarballs 'checkit-tiff_0.1.1.orig.tar.xz' not found at
> '../tarballs/' gbp:error: Pristine-tar couldn't checkout
> "checkit-tiff_0.1.1.orig.tar.xz": fatal: Path
> 'checkit-tiff_0.1.1.orig.tar.xz.delta' does not exist in
> 'refs/heads/pristine-tar' pristine-tar: git show
> refs/heads/pristine-tar:checkit-tiff_0.1.1.orig.tar.xz.delta failed
> Please insert the correct upstream tarball using
>    gbp import-orig --pristine-tar correctly_versioned_orig.tar.gz

I tried this (in fresh cloned git working directory from
https://anonscm.debian.org/cgit/pkg-phototools/checkit-tiff.git/), but
it fails with ff. error:

------- snip ---------
$ git clone
$ cd checkit-tiff
$ gbp import-orig --pristine-tar /tmp/checkit-tiff_0.1.1.orig.tar.gz
gbp:error: Repository does not have branch 'upstream' for upstream
sources. If there is none see
on howto create it otherwise use --upstream-branch to specify it.
------- snap ---------

Could you please explain where I am going wrong? The manual link is not
very helpful to understand the mechanism...

With best regards


Dipl. Inf. (FH) Andreas Romeyke, http://andreas-romeyke.de/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 181 bytes
Desc: Digitale Signatur von OpenPGP
URL: <http://lists.alioth.debian.org/pipermail/pkg-phototools-devel/attachments/20160712/24e4871b/attachment.sig>

More information about the Pkg-phototools-devel mailing list