[pkg-php-pear] Bug#822771: somehow SOLVED: php5/7 mix

Ivan Sergio Borgonovo ivan.s.b at gmail.com
Sun May 15 15:31:09 UTC 2016

I sorted it out.
I created a sid lxc container, installed just php-pear and noticed no 
php5 package was installed and pear was working with no error.

I installed horde in the container.
I took note of the php packages that were installed and installed them 
on the machine that was having problems with pear.

No more pear errors but I've found a couple of related problems to the 

horde was not working for an incompatibility issue in php-text-wiki.
/usr/share/php/Text/Wiki.php suffer from
New objects cannot be assigned by reference

and I had to change all instances of
=& new
= new

Then I got to fix

PHP Warning:  PHP Startup: Unable to load dynamic library 
'/usr/lib/php/20151012/http.so' - /usr/lib/php/20151012/http.so: 
undefined symbol: php_resource_factory_handle_ctor in Unknown on line 0


fixed the problem

Finally I removed all php5 packages and everything was still working.

There are some actual problem in the php5 -> php7 transition and while a 
fresh install of php7 works, coming from php5 may not.
Once I got horde working on that box I didn't install any other php 
package but upgrades took in php7 even when it was not installed and 
this most probably caused the problem.

Unless you help me to track down the "transitioning" issue I can't help 
any further on this. At least I solved *my* problem and I documented how.

I hope it helps to find the issue.

I'll issue other 2 separate bug reports for php-common 
(/usr/lib/php/sessionclean) and php-text-wiki 
(/usr/share/php/Text/Wiki.php) shortly.


Ivan Sergio Borgonovo

More information about the pkg-php-pear mailing list