Bug#758224: Confused about libpulse0 libsystemd-journal0 dependency
fsateler at debian.org
Fri Sep 5 04:33:43 UTC 2014
Sorry for the delay
On Thu, Aug 21, 2014 at 5:50 AM, Godefridus Daalmans
<frits at daalmansdata.eu> wrote:
>> Control: tags -1 moreinfo unreproducible
>> On Fri, Aug 15, 2014 at 10:50 AM, Frits Daalmans <frits at daalmansdata.eu>
>>> Package: pulseaudio
>>> Version: 5.0-6
>>> Severity: normal
>>> Problem: can't install libpulse0:i386 5.0-6 on system with
>>> libpulse0:amd64 5.0-6
>>> I have a mixed amd64 / i386 architecture system, have libpulse0:amd64
>>> upgraded to 5.0-6, and wished to upgrade libpulse0:i386 from 4.0-6+b1 to
>>> for skype.
>>> libpulse0 version 5.0-6 has a new Depends: libsystemd-journal0 (>= 183)
>>> libsystemd-journal0 version 204-7 for amd64 architecture is installed.
>>> I don't know much about libsystemd-journal0, but its description
>>> mentions it
>>> provides an interface for the systemd journal service.
>>> My question / bug report is this: is the dependency of libpulse0 on
>>> libsystemd-journal0 architecture-independent, or must I have a specific
>>> libsystemd-journal0:i386 installed in order to get libpulse0:i386
>>> (that is what apt-get is telling me)
>> Yes, you need that. The systemd libs are multiarch-enabled, so it should
>>> (The latter is not an option because on my, admittedly "experimental",
>>> system it wants to remove pulseaudio and systemd(!!), as well as 260
>>> other packages.
>> This is the part that is broken, then. What does 'apt install
>> libpulse0:i386=5.0-6' say?
>> Felipe Sateler
> Hi Felipe,
> I have run a little experiment: first of all, baseline experiment,
> apt-get install -f doesn't install anything.
> apt-get install libpulse0:i386=5.0-6
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> libpulse0:i386 : Depends: libsystemd-journal0:i386 (>= 183) but it is not
> going to be installed
> E: Unable to correct problems, you have held broken packages.
> libsystemd-journal0 version 208-6 depends on libc6, libgcrypt11, liblzma5,
> apt-get install libsystemd-journal0:i386
> ... (details omitted)
> 114 upgraded, 64 newly installed, 262 to remove and 700 not upgraded.
> it seems to want to remove eclipse, KDE, gnome, pulseaudio, and systemd.
> Then I dug a bit deeper into the depends of libsystemd-journal0:i386
> I don't want to have a complete i386 installation: I normally work with
> amd64, with the minimal number of i386 libraries for skype and a few games.
> apt-cache show libsystemd-journal0:i386=208-6
> I think the relevant info is:
> Package: libsystemd-journal0
> Source: systemd
> Version: 208-6
> Architecture: i386
> Depends: libc6 (>= 2.9), libgcrypt11 (>= 1.5.1), liblzma5 (>=
> 5.1.1alpha+20120614), libselinux1 (>= 1.32)
> Pre-Depends: multiarch-support
> Priority: optional
> If I do a dpkg -l | egrep ' (libc6|libgcrypt11|liblzma5|libselinux1)'
> I get:
> ii libc6:amd64 2.19-7
> amd64 GNU C Library: Shared libraries
> ii libc6:i386 2.19-7
> i386 GNU C Library: Shared libraries
> ii libgcrypt11:amd64 1.5.3-3
> amd64 LGPL Crypto library - runtime library
> ii libgcrypt11:i386 1.5.3-3
> i386 LGPL Crypto library - runtime library
> ii liblzma5:amd64 5.1.1alpha+20120614-2
> amd64 XZ-format compression library
> ii liblzma5:i386 5.1.1alpha+20120614-2
> i386 XZ-format compression library
> ii libselinux1:amd64 2.3-1
> amd64 SELinux runtime shared libraries
> ii libselinux1:i386 2.3-1
> i386 SELinux runtime shared libraries
> hmm.. so all of the dependencies should already be satisfied, for both
> in fact the installed versions are identical for both (seems the sanest).
> Also multiarch-support is in place
> Anyway, for each of the dependencies I did an apt-get -s install, results:
> apt-get -s install libc6:i386
> broken on my computer:
> The following packages have unmet dependencies:
> tar : PreDepends: libacl1 (>= 2.2.51-8) but it is not going to be installed
> PreDepends: libc6 (>= 2.17) but it is not going to be installed
> PreDepends: libselinux1 (>= 1.32) but it is not going to be installed
> apt-get -s install libgcrypt11:i386
> apt-get wants to do an unacceptable solution:
> 156 upgraded, 62 newly installed, 660 to remove and 648 not upgraded.
> apt-get -s install liblzma5:i386
> liblzma5:i386 is already the newest version.
> apt-get -s install libselinux1:i386
> libselinux1:i386 is already the newest version.
This is very strange.
What does `apt-cache policy` say for all the relevant libraries?
(libc6, libpulse0, libsystemd-journal0, all in the i386 versions)
Perhaps you have another conflict in that is confusing everything. Please try:
% aptitude search '?broken'
To see if anything has missing dependencies on your system.
More information about the pkg-pulseaudio-devel