Bug#840220: pulseaudio: no hsp/hfp support built in in pulseaudio

Felipe Sateler fsateler at debian.org
Sun Oct 9 16:41:32 UTC 2016

Control: tags -1 moreinfo

On 9 October 2016 at 13:20, j. outhuis <jouthuis at ldds.nl> wrote:
> Package: pulseaudio
> Version: 9.0-3
> Severity: normal
> Dear Maintainer,
> I've been struggling with this for years now, and waiting for upstream changes
> that would solve the problem: Full bluetooth headset support. Which once worked
> and then all of a sudden went broke. I'm not the only one, as noted on the web.
>    * What led up to the situation?
> Using bluetooth headset with Bluez 5, which dropped hsp/hfp support.
>    * What exactly did you do (or not do) that was effective (or
>      ineffective)?
> Tried to solve the problem with ofono, like suggested on the internet. Compared
> packages and config files with the ones in Xubuntu 16.04, because my headset
> works flawlessly, out of the box when running Xubuntu. No ofono needed either.
> Configured everything exactly like in Xubuntu, as far as possible, may have
> missed something.

Ofono is not necessary AFAICT, pulseaudio has a native backend
(headset=native option).

>    * What was the outcome of this action?
> It still doesn't work, i.e. output is fine, but no input, no sound on the mic.
> 'Pactl list' still says: no support for hsp/hfp.

Could you attach the output of pactl list when you have your device paired?

>    * What outcome did you expect instead?
> I didn't have expectations. As far as I can tell at this moment the Debian
> package just has no hsp/hfp support compiled in. According to Gentoo
> instructions on the web there should be a compile-config like 'ofono-
> headset=yes' for pulseaudio to pick up hsp/hfp support.
> So, please have pulseaudio support ofono functionality, or else tell me what
> I'm overlooking. It's very annoying to see this working on my shadow Xubuntu
> system (which even makes use of the same Debian-packages!) and fail on my main
> Debian-box.

Ubuntu 16.04 has a different version for bluez, this may be related.
The issue might be in bluez and not in pulseaudio. To debug this,
please attach:

1. The output of `pactl list` with the device attached
2. A verbose log of pulseaudio when pairing the device[1].

Please remove the headset=ofono option from the configuration, so that
the native backend is used. AFAICT the ofono support does not bring
the features you need[2]

[1] https://wiki.ubuntu.com/PulseAudio/Log
[2] https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/6.0/#bluetoothhsphfpsupportwithbluez5

Felipe Sateler

More information about the pkg-pulseaudio-devel mailing list