Bug#851826: pulseaudio: USB headset detected, but no sound

Michael Haag haagmj at fastmail.net
Thu Jan 26 03:05:14 UTC 2017

Sorry I didn't get back sooner on this. I've been busy the last few
days, not to mention futzing about with your suggestions and my
equipment trying to figure out the puzzle.

Anyway, I am able to switch to a VT when playing the game, so I assume I
use pactl to change things up? If that's the case, I'll need to spend
some time familiarizing myself with that tool.

I'm using Virtualbox rather the QEMU for the Windows VM. Previously,
I've always had more trouble using pulseaudio in Virtualbox than using
ALSA. Anyway, I tried switching to the pulseaudio driver and had the
same problem.

It's not just USB, either. At least not for the VM. In the VM, both USB
and legacy audio work, with pulseaudio OR ALSA. Doesn't seem to make
much difference. Also, the problem seems to be with the audio stream
coming from the microphone. Playback through the headphones doesn't seem
to be affected.

In short, there is excessive white noise when using the legacy audio
jacks, while there seems to be some kind of latency issue when using
USB--some stuttering and/or slight garbling, but only with the

I suspect it must be due to the headphones use of "surround sound"
processing, since I did not have any issues with my older "stereo"
headset. I just don't get why it seems to be affecting the microphone
rather than the headphones. Guess I'll just have to buy another headset.

Thanks for your time on this, and your suggestions. If nothing else, I
learned a bit more than I knew before. I apologize for wasted time on
your part.

On Mon, Jan 23, 2017, at 20:13, Felipe Sateler wrote:
> On 22 January 2017 at 02:37, Michael Haag <haagmj at fastmail.net> wrote:
> > That works in most instances, but it doesn't work in my use case. I have
> > an older OpenGL/OpenAL/OSS game that takes control of the keyboard and
> > mouse when it loads. This means I cannot access pulseaudio to change
> > devices.
> Can you switch to a different VT? You can try this by using
> ctrl+alt+fN (with N from 1 to 7). There it should be possible to login
> to a text console and query pulseaudio there.
> If that doesn't work, setting up ssh in that computer and logging in
> via that should give you a shell with which we can inspect what
> pulseaudio is doing.
> > Oddly, there is no need to do this when my headset is plugged
> > in using the legacy audio jacks. Sound is directed to BOTH my speakers
> > and my headset.
> This sounds like those are picked up by the system as a single
> surround output rather than two distinct devices.
> >
> > The other case is when I use a Windows-only language learning
> > application which I run in a VM. The headset works with both legacy and
> > USB connections, but the sound quality with USB is so poor the
> > application cannot match my spoken pronunciation to the recorded voice,
> > making it impossible to use the program.
> Is the quality only bad with qemu? Did you set the qemu output driver
> to pulseaudio? https://wiki.archlinux.org/index.php/QEMU#Host
> > Maybe neither of the above can be attributed soley to pulseaudio, but I
> > didn't have this problem with my legacy headset. I can get by with the
> > legacy audio jacks, but the USB problem means I can't use some of the
> > headset features, such as surround sound.
> It doesn't sound like there is any bug in pulseaudio. From what I can
> tell, you just haven't told your app to output to the correct device
> (which is hard because it grabs the mouse and keyboard).
> Also, have you tried to run your OSS program through padsp? This may
> make your app better behaved.
> -- 
> Saludos,
> Felipe Sateler

"Democracy is ... a form of religion; it is the worship of jackals by
jackasses." -- H. L. Mencken

More information about the pkg-pulseaudio-devel mailing list