[Pkg-puppet-devel] Bug#680688: puppet-common depends on libaugeas-ruby1.8 but ruby 1.9 is the default now

Alexander Kurtz kurtz.alex at googlemail.com
Sat Jul 7 23:50:58 UTC 2012

Package: puppet-common
Version: 2.7.17-1
Severity: grave
Justification: Won't parse any manifests using the built-in augeas resource


since 2012-06-03/2012-06-14 ruby 1.9 is the default ruby version in both
unstable and testing:


Newly installed system will therefore have ruby 1.9 installed by
default. However, puppet-common still depends on libaugeas-ruby1.8. This
means that puppet will choke on manifests using the built-in augeas

	$ sudo puppet agent --test
	err: Could not find a suitable provider for augeas
	notice: Finished catalog run in 0.69 seconds

Installing libaugeas-ruby1.9.1 fixes the problem. A quick solution would
therefore be to change the dependency to libaugeas-ruby1.9.1. However, I
think the cleaner approach would be to wait for #680684[0] to be fixed
and to change the dependency to libaugeas-ruby.

Best regards

Alexander Kurtz

PS: You should probably check the other dependencies too: puppet-common
also depends on libshadow-ruby1.8 and suggests librrd-ruby1.8.

[0] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=680684
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-puppet-devel/attachments/20120708/b2c0e39b/attachment.pgp>

More information about the Pkg-puppet-devel mailing list