[Pkg-puppet-devel] Backporting to squeeze

micah micah at riseup.net
Fri Jan 3 18:06:02 UTC 2014

Hi all,

I tried my hand today at backporting for squeeze-backports the updated
version that is in wheezy to fix the security issue. However, I was
unsuccessful and I'm not sure why. If you have any ideas, I'd be
interested in hearing them.

Basically, we know that the puppet-testsuite binary package can't be
built on squeeze-backports, I removed it the last time we did the
backport, but after removing that gem2deb still tries to run test suites
and fails because of:

-I/usr/lib/ruby/vendor_ruby /usr/lib/ruby/vendor_ruby/gem2deb/test_runner.rb
/usr/lib/ruby/vendor_ruby/gem2deb.rb:57:in `system': can't convert nil into String (TypeError)
	from /usr/lib/ruby/vendor_ruby/gem2deb.rb:57:in `run'
	from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:139:in `run_tests_for_version'
	from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:129:in `block in run_tests'
	from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:128:in `each'
	from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:128:in `run_tests'
	from /usr/lib/ruby/vendor_ruby/gem2deb/dh_ruby.rb:72:in `install'
	from /usr/bin/dh_ruby:69:in `block (2 levels) in <main>'
	from /usr/lib/ruby/1.9.1/optparse.rb:1360:in `call'
	from /usr/lib/ruby/1.9.1/optparse.rb:1360:in `block in parse_in_order'
	from /usr/lib/ruby/1.9.1/optparse.rb:1347:in `catch'
	from /usr/lib/ruby/1.9.1/optparse.rb:1347:in `parse_in_order'
	from /usr/lib/ruby/1.9.1/optparse.rb:1341:in `order!'
	from /usr/lib/ruby/1.9.1/optparse.rb:1432:in `permute!'
	from /usr/lib/ruby/1.9.1/optparse.rb:1453:in `parse!'
	from /usr/bin/dh_ruby:73:in `<main>'
dh_auto_install: dh_ruby --install /home/micah/debian/backports/puppet/puppet-2.7.23/debian/tmp returned exit code 1
make: *** [binary] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2

I tried to add export DH_RUBY_IGNORE_TESTS=all, but that didn't seem to
make it work. 

Any ideas how to work around this? It would be a shame to leave those
poor squeeze people in the dark ages, even though everyone should
upgrade ;)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 930 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-puppet-devel/attachments/20140103/b247573a/attachment.sig>

More information about the Pkg-puppet-devel mailing list