Bug#935984: freerdp-x11: crashes with illegal instruction, winpr libraries contain SSE2 instructions on i386

Ondrej Zary linux at zary.sk
Sat Aug 31 16:17:10 BST 2019


Hello,
thanks, freerdp2-x11 works fine.
It's also in stretch-backports so I can use it on my Stretch machines.

On Saturday 31 August 2019 17:08:24 Bernhard √úbelacker wrote:
> Hello Ondrej Zary,
> while looking through bug reports for some random
> packages I got to your report.
> I guess your system got updated at least from Stretch to Buster,
> therefore you might have freerdp-x11 installed while that
> is not part of the official Buster release.
> It got also removed from Sid, therefore this report
> would just be a concern for Stretch.
> 
> If I see it right, it got replaced by freerdp2-x11.
> As far as I see that contains (from your short objdump test)
> no SSE2 instructions. Maybe that works for your purpose.
> 
> Attached patch shows an incomplete attempt to build without
> sse2, but unfortunately that fails, would need some more work.
> 
> Kind regards,
> Bernhard
> 
> 
> benutzer at debian:~$ objdump -d /usr/lib/i386-linux-gnu/libwinpr2.so.2.0.0 | grep xmm
> benutzer at debian:~$ objdump -d /usr/bin/xfreerdp | grep xmm
> benutzer at debian:~$
> 


-- 
Ondrej Zary



More information about the pkg-remote-team mailing list