[DRE-maint] Bug#892558: bug 892558 is forwarded to https://github.com/rodjek/rspec-puppet/issues/670, tagging 892558

intrigeri intrigeri at debian.org
Sun Feb 10 14:55:14 GMT 2019


(Taking a quick look as I'd love to see ruby-puppetlabs-spec-helper in
Buster, but it's blocked by ruby-rspec-puppet which won't migrate due
to this bug. Was hoping for a quick fix since this is tagged
fixed-upstream, but looks like it's not that simple.)

Georg Faerber:
> forwarded 892558 https://github.com/rodjek/rspec-puppet/issues/670

This upstream bug is marked as fixed in 2.6.12.

FTR I've tried importing 2.6.12 and I see 3 failures during the build:

  1) trusted_facts without node set should contain Notify[certname-my_node.my_node]
     Failure/Error: it { should contain_notify("certname-my_node.my_node") }
       expected that the catalogue would contain Notify[certname-my_node.my_node]
     # ./spec/classes/trusted_facts_spec.rb:7:in `block (3 levels) in <top (required)>'

  2) trusted_facts without node set should contain Notify[hostname-my_node]
     Failure/Error: it { should contain_notify("hostname-my_node") }
       expected that the catalogue would contain Notify[hostname-my_node]
     # ./spec/classes/trusted_facts_spec.rb:9:in `block (3 levels) in <top (required)>'

  3) trusted_facts without node set should contain Notify[domain-my_node]
     Failure/Error: it { should contain_notify("domain-my_node") }
       expected that the catalogue would contain Notify[domain-my_node]
     # ./spec/classes/trusted_facts_spec.rb:10:in `block (3 levels) in <top (required)>'

That's of course much better than the 78 failures Adrian originally
reported, but it suggests there's more to it than rspec-puppet#670,
so perhaps forwarded + fixed-upstream is not entirely correct.

Then I've tried importing the latest upstream release (currently
2.7.2) and I see 5 test failures — the same 3 as above and
2 additional ones:

  1) test::registry should compile into a catalogue without dependency cycles
     Failure/Error: it { should compile.with_all_deps }
       error during compilation: Evaluation Error: Error while evaluating a Resource Statement, Unknown resource type: 'registry::value' (file: /<<PKGBUILDDIR>>/spec/fixt
ures/modules/test/manifests/registry.pp, line: 2, column: 3) on node (node's fully qualified domain name)
     # ./spec/classes/test_registry_spec.rb:10:in `block (2 levels) in <top (required)>'

  5) ensure_packages should create the resource in the catalogue
     Failure/Error: before { subject.execute('facter') }

       undefined method `execute' for nil:NilClass
     # ./spec/functions/ensure_packages_spec.rb:4:in `block (2 levels) in <top (required)>'


More information about the Pkg-ruby-extras-maintainers mailing list