[Pkg-rust-maintainers] Bug#932938: librust-docopt-dev (build-)depends on obsolete virtual package.

peter green plugwash at p10link.net
Wed Jul 24 23:04:00 BST 2019

Package: librust-docopt-dev
Version: 1.0.2-1
Severity: serious
Tags: buster, sid

librust-docopt-dev depends on the virtual package librust-strsim-0.7+default-dev which is no longer provider by librust-strsim-dev. The virtual package seems to have been renamed to  librust-strsim-0.9+default-dev . The rust-docopt source package also has a build-dependency on librust-strsim-0.7+default-dev so this does not appear to be fixable with a binnmu.

Right now the dependency issue only affects sid, however this dependency issue is blocking the migration of rust-strsim to bullseye, which in turn is making rust-clap's build-dependencies unsatisfiable in bullseye, so this needs to be fixed for bullseye.

More information about the Pkg-rust-maintainers mailing list