[Pkg-rust-maintainers] Bug#948632: rust-bcder: Build-depends on older rust-smallvec than is in unstable

Steve Langasek steve.langasek at canonical.com
Sat Jan 11 02:17:22 GMT 2020

Source: rust-bcder
Version: 0.4.1-1
Severity: serious
User: ubuntu-devel at lists.ubuntu.com
Usertags: origin-ubuntu focal

rust-bcder build-depends on librust-smallvec-0.6+default-dev, but
rust-smallvec is now at version 1.1 in unstable:

$ sudo apt build-dep rust-bcder
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:rust-bcder : Depends: librust-smallvec-0.6+default-dev (>= 0.6.10-~~) but it is not installable
E: Unable to correct problems, you have held broken packages.

Please update rust-bcder for compatibility with the current

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                   https://www.debian.org/
slangasek at ubuntu.com                                     vorlon at debian.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://alioth-lists.debian.net/pipermail/pkg-rust-maintainers/attachments/20200110/a0fd8047/attachment.sig>

More information about the Pkg-rust-maintainers mailing list