[Pkg-rust-maintainers] Draft Rust packaging policy for review

Ghislain Vaillant ghisvail at gmail.com
Wed Dec 7 12:20:32 UTC 2016

I was about to ask the same thing as Ximin about the versioning.

Also, may I suggest to recommend (not enforce) a naming scheme for the
source package as well. Something like rust-$(CRATE_NAME).

The reason for this is that a lot of the current crates are wrappers or
ports around existing libs and their name will likely collide with an
implementation in another language.

Python recommends using the python- prefix for source packages, ruby
enforces this with the ruby- prefix.


More information about the Pkg-rust-maintainers mailing list