[Pkg-rust-maintainers] Draft Rust packaging policy for review
josh at joshtriplett.org
Thu Dec 8 04:47:17 UTC 2016
On Wed, Dec 07, 2016 at 12:20:32PM +0000, Ghislain Vaillant wrote:
> I was about to ask the same thing as Ximin about the versioning.
I originally did so to avoid potential conflicts between (for instance)
the versioned package name of major version 3 of the "gtk" crate and the
unversioned package name of the "gtk-3" crate; the inclusion of the '.'
in the Debian package name prevented such a conflict, because crate
names can't include a '.'.
However, since we don't support unversioned package names anymore, that
potential conflict can't occur. I'll tweak debcargo and dh-cargo to
change this for simplicity.
> Also, may I suggest to recommend (not enforce) a naming scheme for the
> source package as well. Something like rust-$(CRATE_NAME).
> The reason for this is that a lot of the current crates are wrappers or
> ports around existing libs and their name will likely collide with an
> implementation in another language.
> Python recommends using the python- prefix for source packages, ruby
> enforces this with the ruby- prefix.
I currently generate source packages named rust-cratename-version. I
just added that to the policy as a "should".
More information about the Pkg-rust-maintainers