[Pkg-samba-maint] Bug#409987: Can't upgrade samba-common

Justin Hartman justin at japroductions.co.za
Wed Feb 7 00:34:43 CET 2007

> Ok, then why is /etc/rc2.d/K09samba a dangling symlink?  Sorry, I assumed
> this was because the init script was missing, but of course there could be
> other explanations.  Still, that error message is the root problem you need
> to address, and it's not a samba bug.

The problem as it would appear was not with the actual init script but
rather the symlink.

I ran the following and it solved my problem:

debian:/home/justin# cd /etc/rc2.d/
debian:/etc/rc2.d# ln -sf ../init.d/samba K09samba
debian:/etc/rc2.d# apt-get -f install

Thanks for your help Steve.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.alioth.debian.org/pipermail/pkg-samba-maint/attachments/20070207/e03db7db/attachment.pgp

More information about the Pkg-samba-maint mailing list