[Pkg-samba-maint] Use SAMBA with QEMU

Philippe Combes Philippe.Combes at ens-lyon.fr
Mon May 7 16:34:07 UTC 2007

Hi all,

Like many people, I would like to use QEMU with its -smb option.
I am running Debian sid, frequently updated (last update was today)

With this -smb option, QEMU starts a new SAMBA server with its own 
configuration (stored in /tmp/qemu.XXXX/smb.conf) provided it can find 
/usr/sbin/smbd. The configuration uses a "private dir =" option.
The problem is that qemu cannot launch the SAMBA server.

Some said a few years ago that it was due to fhs.patch and the removal 
of lp_private_dir() in passdb/secrets.c
So I tried several other solutions, manipulating the patch file, using 
--wihtou-fhs (but the patch was still applied), I rebuilt the package 
several times but none of my attempts worked.

I do not know what I can do now to solve the problem. As it has been a 
known bug for a few years, I guess either you do not care about fixing 
it, or it is not that simple to fix.
I hope it is the former case, and thus I beg you to help me fixing it...



More information about the Pkg-samba-maint mailing list