[Pkg-samba-maint] DO NOT REPLY [Bug 6230] 'force group' still broken in 3.3.2

samba-bugs at samba.org samba-bugs at samba.org
Sun Mar 29 12:42:36 UTC 2009


korn-bugzilla.samba.org at elan.rulez.org changed:

           What    |Removed                     |Added
                 CC|                            |korn-
                   |                            |bugzilla.samba.org at elan.rule
                   |                            |z.org

------- Comment #4 from korn-bugzilla.samba.org at elan.rulez.org  2009-03-29 07:42 CST -------
(In reply to comment #3)


> "denied due to security descriptor"
> Very, very likely the smb.conf is not the whole story, but the user has put
> stuff into share_info.tdb. If the user does not intend to use security
> descriptors for shares, an option to test might be moving share_info.tdb away.
> Can you test that?
> If share_info.tdb intentionally contains security descriptors, please also
> upload that together with the output of "net getlocalsid" and "net
> getdomainsid".

Sorry, I didn't include this in my original report: I did come across the
suggested "solution" of removing share_info.tdb and tried, but it didn't help.
(It would also have surprised me if it had, as this is a completely new samba
setup and to the best of my knowledge I didn't do anything fancy with

Anyway, just to make sure, I tested again. I stopped smbd and nmbd, removed
share_info.tdb, uncommented the force group line in smb.conf, started the
daemons and tried to connect to the share via smbclient. Sure enough, I get
"make_connection: connection to store denied due to security descriptor." in
the log.

To be absolutely sure, I again commented the force group line out, restarted
the daemons again, and tried smbclient again, and this time, it worked.

Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.

More information about the Pkg-samba-maint mailing list