[Pkg-samba-maint] Bug#576415: Bug#576415: samba: nmbd often exits with 'getaddrinfo failed for name [Address family for hostname not supported]'

Christian PERRIER bubulle at debian.org
Sun Apr 4 14:31:16 UTC 2010

Quoting Sam Morris (sam at robots.org.uk):
> Package: samba
> Version: 2:3.4.7~dfsg-1
> Severity: normal

> I run Debian in a VirtualBox virtual machine and often find that I am
> unable to resolve the hostname of the system from my Windows host. This
> is always caused by nmbd not running in the virtual machine.
> I'm attaching my log.nmbd file; this was produced with 'log level' set
> to 3. It appears that nmbd was launched but then immediately failed with
> these messages:
> [2010/03/29 20:45:01,  3] nmbd/nmbd.c:948(main)
>   Opening sockets 137
> [2010/03/29 20:45:01,  3] ../lib/util/util_net.c:56(interpret_string_addr_internal)
>   interpret_string_addr_internal: getaddrinfo failed for name [Address family for hostname not supported]
> [2010/03/29 20:45:01,  0] nmbd/nmbd.c:693(open_sockets)
> I have tried to correlate this time with other log messages and it
> appears that the system was still booting when the message occurred.
> Here are the syslog messages from around the same time:

networkmlanager seems to be starting *after* nmbd.

Could you do "ls /etc/rc2.d/*network-manager* /etc/rc2.s§*samba*"?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-samba-maint/attachments/20100404/65f39045/attachment.pgp>

More information about the Pkg-samba-maint mailing list