[Pkg-samba-maint] Bug#767896: samba: cannot access shared directories with a literal asterisk character in their name

Arthur Marsh arthur.marsh at internode.on.net
Mon Nov 3 11:11:36 UTC 2014

Package: samba
Version: 2:4.1.13+dfsg-2
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

Some upgrade that is difficult to track down, but appears to have happened in
the last week of running / upgrading Debian unstable.

   * What exactly did you do (or not do) that was effective (or

Tried downgrading kernel on client and server.

Tried mounting share on same machine as server, same problem observed.

   * What was the outcome of this action?
   * What outcome did you expect instead?

so I made a directory called test*:

mkdir test\*

If I check for it on a client machine I get:

ls test\*

ls: reading directory test*: Not a directory

If I do the following on the client machine I get:

ls -al|grep test

ls: test*: No such file or directory

then later on in the listing:

drwxr-xr-x   2 root     root              0 Nov  3 21:11 test*

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (500, 'oldstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.18.0-rc2 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages samba depends on:
ii  adduser                              3.113+nmu3
ii  dpkg                                 1.17.21
ii  libasn1-8-heimdal                    1.6~rc2+dfsg-8
ii  libbsd0                              0.7.0-2
ii  libc6                                2.19-12
ii  libcomerr2                           1.42.12-1
ii  libhdb9-heimdal [heimdal-hdb-api-8]  1.6~rc2+dfsg-8
ii  libkdc2-heimdal                      1.6~rc2+dfsg-8
ii  libkrb5-26-heimdal                   1.6~rc2+dfsg-8
ii  libldb1                              1:1.1.17-1
ii  libpam-modules                       1.1.8-3.1
ii  libpam-runtime                       1.1.8-3.1
ii  libpopt0                             1.16-10
ii  libpython2.7                         2.7.8-11
ii  libroken18-heimdal                   1.6~rc2+dfsg-8
ii  libtalloc2                           2.1.1-2
ii  libtdb1                              1.3.1-1
ii  libtevent0                           0.9.21-1
ii  lsb-base                             4.1+Debian13+nmu1
ii  multiarch-support                    2.19-12
ii  procps                               2:3.3.9-8
ii  python                               2.7.8-2
ii  python-dnspython                     1.12.0-1
ii  python-ntdb                          1.0-5
ii  python-samba                         2:4.1.13+dfsg-2
pn  python2.7:any                        <none>
ii  samba-common                         2:4.1.13+dfsg-2
ii  samba-common-bin                     2:4.1.13+dfsg-2
ii  samba-dsdb-modules                   2:4.1.13+dfsg-2
ii  samba-libs                           2:4.1.13+dfsg-2
ii  tdb-tools                            1.3.1-1
ii  update-inetd                         4.43

Versions of packages samba recommends:
ii  attr               1:2.4.47-2
ii  logrotate          3.8.7-1
ii  samba-vfs-modules  2:4.1.13+dfsg-2

Versions of packages samba suggests:
ii  bind9          1:9.9.5.dfsg-5
ii  bind9utils     1:9.9.5.dfsg-5
pn  ctdb           <none>
pn  ldb-tools      <none>
ii  ntp            1:4.2.6.p5+dfsg-3.1
pn  smbldap-tools  <none>
ii  winbind        2:4.1.13+dfsg-2

-- debconf information:
* samba/run_mode: daemons
* samba/generate_smbpasswd: false

More information about the Pkg-samba-maint mailing list