[Pkg-samba-maint] Bug#763762: samba-libs depends on libcups2 (>= 1.6.0) which makes it hard to install cups 1.5

Michal Hocko mstsxfx at gmail.com
Thu Oct 2 13:41:56 UTC 2014

Package: samba-libs
Version: 2:4.1.11+dfsg-1
Severity: normal

after having serious problems with the current cups 1.7 version
I have decided to go back to 1.5 version. The downgrade stumbled
over samba-libs dependency, though, which in turn requires a lot of
downgrades including the whole kde stack from 4.14 to 4.8 resulting in
an unpleasant:
--- Packages being removed because they are no longer used (66)
--- Packages being automatically held in their current state (14)
--- Packages being automatically installed to satisfy dependencies (39)
--- Packages to be downgraded (90)
--- Packages being held back (12)
--- Packages to be removed (14)

This looks like a major pain just because of a single dependency. So I
was curious whether samba-libs really needs libcups >= 1.6 or it would
work with older versions as well.
I cannot seem to find anything in the changelog that would mentioned
bump up of the dependency because of a bug or feature. The previous
libsmbclient which seems to be behind most of the dependency hell didn't
depend on samba at all
Version: 2:3.6.6-6+deb7u4
Depends: libc6 (>= 2.10), libcap2 (>= 2.10), libcomerr2 (>= 1.01), libgssapi-krb5-2 (>= 1.10+dfsg~), libk5crypto3 (>= 1.6.dfsg.2), libkrb5-3 (>= 1.10+dfsg~), libldap-2.4-2 (>= 2.4.7), libtalloc2 (>= 2.0.4~git20101213), libtdb1 (>= 1.2.7+git20101214), libwbclient0 (>= 2:3.6.0~pre3), zlib1g (>= 1:1.1.4)

This leaves a hope that 1.6 dependency came with the new samba-libs
which used the current up-to-date libcups version. But I might be
completely wrong here of course.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.17.0-rc7 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages samba-libs depends on:
ii  libacl1              2.2.52-2
ii  libasn1-8-heimdal    1.6~rc2+dfsg-8
ii  libattr1             1:2.4.47-2
ii  libbsd0              0.7.0-2
ii  libc6                2.19-11
ii  libcap2              1:2.24-6
ii  libcomerr2           1.42.12-1
ii  libcups2             1.7.5-3
ii  libgnutls-deb0-28    3.3.8-2
ii  libgssapi3-heimdal   1.6~rc2+dfsg-8
ii  libhcrypto4-heimdal  1.6~rc2+dfsg-8
ii  libhx509-5-heimdal   1.6~rc2+dfsg-8
ii  libkrb5-26-heimdal   1.6~rc2+dfsg-8
ii  libldap-2.4-2        2.4.39-1.1+b1
ii  libldb1              1:1.1.17-1
ii  libntdb1             1.0-5
ii  libpam0g             1.1.8-3.1
ii  libpopt0             1.16-10
ii  libpython2.7         2.7.8-7
ii  libtalloc2           2.1.1-2
ii  libtdb1              1.3.1-1
ii  libtevent0           0.9.21-1
ii  libwbclient0         2:4.1.11+dfsg-1
ii  multiarch-support    2.19-11
ii  python-talloc        2.1.1-2
ii  zlib1g               1:1.2.8.dfsg-2

samba-libs recommends no packages.

samba-libs suggests no packages.

-- no debconf information

Michal Hocko

More information about the Pkg-samba-maint mailing list