[Pkg-samba-maint] Bug#961867: python3?-talloc multiarch support is broken because of the dependency on python

Francois Gouget fgouget at free.fr
Sat May 30 17:25:55 BST 2020

Package: python-talloc
Version: 2.1.14-2
Severity: normal

Dear Maintainer,

python-talloc is 'multiarch: same' but the i386 package is not coinstallable
with the amd64 one because of their python dependency.

The issue is that python-talloc:i386 depends on python:i386, while
python-talloc:amd64 depends on python:amd64. But python is multiarch
allowed and this causes a conflict when trying to install both i386 and

python3-talloc 2.3.0-5 has the same issue in Debian Testing but with
python3 instead of python.

Maybe what was intended is to have a python3:any dependency instead of a
regular python3 one? So this would make it:

Depends: libtalloc2 (= 2.3.0-5), python3:any (<< 3.9), python3:any (>= 3.8~), libc6 (>= 2.4), libpython3.8 (>= 3.8.2)

Unfortunately I don't know enough about python3-talloc to know if that would make sense. This multiarch howto section seems particularly relevant:

The impact is that this prevents Wine from using the libnetapi
library for 32-bit Windows applications because libnetapi is part of
samba-libs, which depends on python3-talloc.

-- System Information:
Debian Release: 10.4
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-8-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE=fr:en_US (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages python-talloc depends on:
ii  libc6         2.28-10
ii  libpython2.7  2.7.16-2+deb10u1
ii  libtalloc2    2.1.14-2
ii  python        2.7.16-1

python-talloc recommends no packages.

python-talloc suggests no packages.

-- no debconf information

More information about the Pkg-samba-maint mailing list