Bug#925324: libsdl1.2-dev: problem with compilating with SDL

Valery grivalera at yandex.ru
Sat Mar 23 05:43:18 GMT 2019

Package: libsdl1.2-dev
Version: 1.2.15+dfsg2-4
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

	compiling messages that: 

     /usr/include/SDL/SDL_opengl.h:116: error: "GL_GLEXT_VERSION" redefined [-Werror]
     #define GL_GLEXT_VERSION 29
In file included from /usr/include/GL/gl.h:2055,
                 from /usr/include/SDL/SDL_opengl.h:46,
                 from src/Basescape/../Engine/OpenGL.h:14,
                 from src/Basescape/../Engine/Screen.h:22,
                 from src/Basescape/CraftEquipmentState.cpp:23:
/usr/include/GL/glext.h:54: note: this is the location of the previous definition
 #define GL_GLEXT_VERSION 20180725

I have found same error at https://bugzilla.redhat.com/show_bug.cgi?id=1662778
and there are way to repeat error:

printf '#include <SDL_opengl.h>\n' | gcc $(sdl-config --cflags) -x c -c -

   * What exactly did you do (or not do) that was effective (or

    I have compiled an OpenXcom project at my system, it appears during compilation
    note: it was succesfully compilated on two other debian 9 systems.
   This one firstly debian 9, was changed to testing and upgraded to newest kernel and mesa.

   * What was the outcome of this action?

    I haven't idea how to pass it.
    I tried change #ifndef GL_GLEXT_VERSION at /usr/include/SDL/SDL_opengl.h but
    it make more errors, It seems like version number is important.

   * What outcome did you expect instead?

   Maybe change libsdl1.2-dev? I have newest one

*** End of the template - remove these template lines ***

-- System Information:
Debian Release: 9.5
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=ru_RU.UTF-8, LC_CTYPE=ru_RU.UTF-8 (charmap=UTF-8), LANGUAGE=ru_RU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages libsdl1.2-dev depends on:
ii  libasound2-dev                 1.1.7-2
ii  libcaca-dev                    0.99.beta19-2+b3
ii  libglu1-mesa-dev [libglu-dev]  9.0.0-2.1+b2
ii  libpulse-dev                   12.2-3
ii  libsdl1.2debian                1.2.15+dfsg2-4
ii  libx11-dev                     2:1.6.7-1
ii  libxext-dev                    2:1.3.3-1+b2

libsdl1.2-dev recommends no packages.

libsdl1.2-dev suggests no packages.

-- no debconf information

More information about the Pkg-sdl-maintainers mailing list