Bug#803531: systemd: timeout mounting /home (btrfs) at boot

Brian May bam at debian.org
Thu Dec 3 23:43:12 GMT 2015

Martin Pitt <mpitt at debian.org> writes:

> I tested this with the attached script (in two variants),  and I don't
> see anything generally wrong with it; sure, the two devices have the
> exact same UUID thus the symlink will randomly point to one or the
> other, but both of my devices have ID_BTRFS_READY=1. I tried this some
> 20 times. However, this is using scsi_debug (i. e. a fake kernel
> RAM-backed SCSI drive), not real iron. This could likely be a timing
> problem.
> So this needs to be reproduced with a full install cycle and adding to
> fstab etc.

I note your tests use "blkid -p /dev/sdb1" however that doesn't appear
to display the "SYSTEMD_READY" flag.

"udevadm info /dev/sdb1" or "udevadm info /dev/sdb1 | grep SYSTEMD" might be better.

Right now it is telling me that /dev/sdb1 is has SYSTEMD_READY=0, and
/dev/sdc1 doesn't have this attribute.

> "followed the instructions" wasn't quite what I was aiming for :-)
> I tried that with
>   mkfs.btrfs /dev/sdb1
>   mount /dev/sdb1 /mnt
>   btrfs device add /dev/sdb2 /mnt
> Is that roughly what you did?

Pretty much.

I also did a "btrfs balance start -dconvert=raid1 -mconvert=raid1 /mnt"
- be really surprised if that has any impact on this test however.

Oh, except I note that you used /dev/sdb1 and/dev/sdb2 on the same
harddisk. I used seperate harddisks for both. Wonder if that matters?
Brian May <bam at debian.org>

More information about the Pkg-systemd-maintainers mailing list