Bug#777601: systemd: Loosing LXC memory cgroups after service install

Martin Pitt mpitt at debian.org
Thu Feb 12 12:24:45 GMT 2015

Control: tag -1 confirmed
Control: fixed -1 218-1

Hey Pierre,

Pierre Mavro [2015-02-10 15:45 +0100]:
> Let's say I've an LXC container called jessie running on jessie. The
> container is started and I can see the memory is correctly visible in
> the cgroup fs:
> $ ls /sys/fs/cgroup/memory/lxc/jessie/
> [...]
> Then let's say I install samba (works with other services):
> $ apt-get -y install samba
> Then the cgroup fs for the container disappeared :
> $ ls /sys/fs/cgroup/memory/lxc/jessie/
> ls: cannot access /sys/fs/cgroup/memory/lxc/jessie/: No such file or
> directory

I can reproduce this with systemd 215 from jessie/unstable. For the
record, it's not necessary to install samba, "systemctl restart
haveged" worked for me too.

I remember a similar problem when I worked on Ubuntu's "user LXC
container" support/patch, but this issue got fixed with 217 or 218.
Indeed I can't reproduce this report with the experimental version,
marking as fixed there; can you confirm?

How much of an actual issue is that in practice? At least for me
reloading a service only triggers the cleanup of empty cgroups. Indeed
LXC creates the cgroups in all controllers, but only actually puts the
processes in the container in some of them (e. g. perf_event and
freezer, but not devices and memory), and those which are non-empty
stay alive for me. So isn't that just a rather cosmetical problem at
this point?


Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://alioth-lists.debian.net/pipermail/pkg-systemd-maintainers/attachments/20150212/86c509f3/attachment-0002.sig>

More information about the Pkg-systemd-maintainers mailing list