Bug#821395: systemd: first login attempt with GDM fails when user services are present

Felipe Sateler fsateler at debian.org
Mon Apr 18 14:09:42 BST 2016

Control: tags -1 moreinfo

On 18 April 2016 at 09:48, David Banks <amoebae at gmail.com> wrote:
> Package: systemd
> Version: 229-4
> Severity: normal
> Having user services defined under ~/.config/systemd/user can cause the initial
> login attempt after a restart to fail.  Only the first login attempt will fail,
> and it will cause a message in syslog thusly
>     Apr 18 11:54:22 motylyok /usr/lib/gdm3/gdm-x-session[1939]: Unable to register display with display manager(II) UnloadModule: "synaptics"
> This is clearly two logs that have been mixed up somehow, but the message
> 'unable to register display with display manager' is the relevant one.
> These symptoms happened while I was using the third-party 'profile-sync-daemon'
> package, so this may be a confounding factor.  This service uses systemd timers.
> Removing these user services instantly resolved the problem.  I don't know why.
> I also have the following message in syslog:
>     Apr 18 13:07:18 motylyok /usr/lib/gdm3/gdm-x-session[2083]: dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
> This does not seem to affect the ability to login though.
> I am using xmonad as a window manager, logged in through gdm.  It seems that
> this is a recent occurrence, as login worked fine for a long time.  A few other
> related symptoms manifested alongside this proble.  For instance, sometimes
> login would hang, or abort altogether, that seemed to be provoked by switching
> away from X to the virtual console.
> I believe that the following problems in other distributions may be related:
> * https://bugzilla.redhat.com/show_bug.cgi?id=1263208
> * https://bbs.archlinux.org/viewtopic.php?id=200410
> The problem described as "case 1" by wsha in the initial post of the above
> bbs.archlinux.org thread is exactly the same problem described by this bug.
> Sorry that this bug can't be more helpful, however there are so many interacting
> components here that it's very difficult to give a useful diagnosis.  I have now
> worked around the problem locally by removing the user services.

Could you please attach the faulty services? Also, the output of
`journalctl -u $youruser -b` (this gives us the user log messages for
the current boot) would be useful as well.


Felipe Sateler

More information about the Pkg-systemd-maintainers mailing list