Bug#921687: systemctl just hangs on stoping or starting mysql-server-5.7

Ansgar ansgar at debian.org
Fri Feb 8 10:34:23 GMT 2019

On Fri, 2019-02-08 at 00:35 +0100, Eduard Bloch wrote:
> So, out of blue my system cannot shutdown or reboot anymore. Hangs on something with mysql.
> So I tried to remove it since I don't need it here. Result: it fails to
> remove it, and just hangs there. I tried to update systemd, it's still
> ends in a frozen dpkg, doing deadlocking package configurations.
> From user POV this is a disaster!

>From your process list and `systemctl status mysql` output, it looks
like the MySQL service has been trying to get stopped for 9min.  I
looked at the mysql.service file shipped in mysql-server-5.7_5.7.25-
1_amd64.deb and it sets a timeout of 10min:

| TimeoutSec=600
+---[ mysql.service ]

I wonder if the process did continue if you wait a bit longer?

Besides that, I'm not sure systemd can do much differently here: it
just tries to follow the commands given, but mysql seems to not shut
down for some reason.

Could you include the processes related to mysql in your list?  Does
the mysql log include any hints what might be going wrong?

It might be more appropriate for this bug to be reassigned to the
mysql-server-5.7 package; I've included the maintainers in Cc as I
don't know much about MySQL and won't be much of a help here.


More information about the Pkg-systemd-maintainers mailing list