Bug#985255: Systemd initiates fsckd for no apparent reason

haagmj haagmj at zoho.com
Mon Mar 15 06:33:23 GMT 2021

Package: systemd

Version: 247.3-1

Every few system restarts fsckd runs and fails with the following error message:

[TIME] timed out waiting for device /dev/sdb2

I am subsequently dropped into a terminal session (busybox?)

There are no problems with the filesystem or the hard disk (SSD) in question. 

Pressing Ctl-Alt-Del almost always results in a successful reboot. Rarely, 

the system will halt again with the same error message requiring yet 

another reboot. In any case, the system eventually boots without error.

This problem first appeared on a hard disk that has since been replaced.

Manually initiating fsck on /dev/sdb2 has never resulted in an error 

on either the old disk or the new one. Occasionally, systemd reports an 

error indicating missing system files (/dev/sda1). Again, manually 

running fsck against the referenced partition has never resulted in an error.

I tried sending this via reportbug, but I've never received an email reply

indicating it was received. I was previously running Debian Buster without

issue. I upgraded to Debian Bullseye several months ago, but did not 

experience this problem until sometime after the initial upgrade.

If you require additional information, feel free to contact me with your

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/pkg-systemd-maintainers/attachments/20210315/95817742/attachment.htm>

More information about the Pkg-systemd-maintainers mailing list