[Pkg-sysvinit-devel] Make init.d/skeleton a very simple init.d script?

Petter Reinholdtsen pere at hungry.com
Mon Feb 3 10:38:01 UTC 2014

[Henrique de Moraes Holschuh]
> I think it would be best to have a way to override the actual
> commands used to start/stop/restart/force-reload.

Yeah, I suspect so too, and spliting the functions in two is probably
the way to go then.  Perhaps use do_start() and do_start_cmd() and

> Also, we need to document how people should override things,
> redefining the functions is not obvious _and_ a shell might decide
> to spew out warnings, so I favor the "{$foo_override:=foo}" way of
> calling these functions...  if it looks like "dh", it is more likely
> people will use it correcty :-)

Can you rewrite the code to be the way you propose, to give me a
better idea how you vision it?  Btw, when can shell spew warnings when
redefining functions?  Never seen that myself.  I fear we "polute" the
environment name space too much by adding variables for every function
we can call, but perhaps we should not care about that much.

I agree that we need documentation explaining how to use it.  Should
we write a init-d-script manual page, or just a README?  I suspect a
manual page is the best option.

We can discuss more in #pkg-sysvinit on irc.debian.org, if you
like. :)

Happy hacking
Petter Reinholdtsen

More information about the Pkg-sysvinit-devel mailing list