[Pkg-sysvinit-devel] Bug#738775: insserv: Insserv 1.16 tries to connect to systemd even though system is running on sysv-init

Jan Binder wheel at herr-der-mails.de
Wed Feb 12 20:35:27 UTC 2014

Package: insserv
Version: 1.16.0-1
Severity: grave
Justification: renders package unusable

Dear Maintainer,

   * What led up to the situation?
    After having installed insserv 1.16, installing any version of initscripts
    leads to the error message shown in bug #738532.

   * What exactly did you do (or not do) that was effective (or
   Dist-upgraded to experimental, initscrpts install failed with error.
   Tried to install any available verion of initscripts, all failed in the same manner.
   Forcefully removed initscripts, forcefully downgraded insserv to 1.14.
   Installing initscripts now worked.

   * What was the outcome of this action?
   Cannot install initscripts after installing insserv 1.16 because it tries to connect to 
   systemd which is present on the system but not used as PID 1.

   * What outcome did you expect instead?
   insserv should not fail when it cannot connect to systemd and systemd is not running as PID 1.
   Instead it should talk to sysv-init or whatever else it supports.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.13.0-rc8 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages insserv depends on:
ii  libc6        2.18-0experimental1
ii  libdbus-1-3  1.8.0-1

insserv recommends no packages.

Versions of packages insserv suggests:
ii  bootchart2  0.14.4-3

-- debconf information:
  insserv/enable: false

More information about the Pkg-sysvinit-devel mailing list